Plugin Installation Failed because of Error about MDAC 2.7

Follow

Not what you were looking for? Search here.

Problem:

Installation of the ALL In learning Browser plugin is interrupted by this error:

-----------------------------------------------------------------------------------------------------

Microsoft Data Access Component MDAC 2.7 SP1 cannot be installed on this Machine.

MDAC 2.7 SP1 requires any of the following configurations:

  • Microsoft Windows 98 with the Y2K Update 2 and Internet Explorer 4.01 SP2 or later
  • Microsoft Windows 98 Second Edition
  • Microsoft Windows Millennium
  • Microsoft NT® 4 SP5 (or greater) and IE 4.01 SP2 or later
  • Microsoft Windows 2000

Setup will exit now. Please restart the Setup after installing the necessary updates to this machine.

------------------------------------------------------------------------------------------------------


Solution:

We've seen this once, and the user was using Windows 7, and it appeared that the operating system was missing components. 

We downloaded and installed MDAC 2.8 onto the computer from Microsoft.

Then upon advice given in a Microsoft KB article, we went to the folder we had downloaded the AILPlugin download into, right-clicked the file, chose "Properties," chose the "Compatibility" tab, and checked the top option to install this file in compatibility mode and tried some of them - the one that worked was "Vista (Service Pack 2)." Then we clicked "Apply," OK, and double clicked the AILPlugin exe and installed it. This resolved the problem, though we do not know the details as to why or if it will work for anyone else.

Powered by Zendesk