Mac Users - After Updating the Plugin, You Keep Seeing Prompt to Install It Again

Follow

Not what you were looking for? Search here.

Normally, this issue can happen if the plugin wasn't installed correctly (for example, you downloaded the plugin but didn't double-click it and follow all instructions), or you have not restarted your browsers after installing.

However, on November 12th, 2015, changes were made that will affect any users who have updated their plugin in the two weeks prior (since October 29th).

What changed?
Since releasing the new version of our Mac plugin on October 29th, we've learned that some schools are using versions of OSX or browsers that are years out of date, they are not allowed to upgrade, and our new plugin is incompatible with those older versions. We've deemed this is a significant enough problem that we've decided to "roll back" our newest plugin for now to the older one that works for everyone.

how does this affect Mac users?
If you have installed the new plugin since October 29th, you will be prompted to upgrade the plugin again, but no matter how many times you try, you will still see the prompt to download and install the new plugin. Unfortunately, this is because some files need to be manually deleted before you can successfully roll back to the older plugin. Steps are below.

Also, note that the older version does not support some of the newer bubble sheets we offer. It can only be used to scan 5-part 40-question and 60-question sheets. The other sheets can be graded with our ASSIST app for iPhone or iPad, or with a PC. 


Here are the steps to fix the problem:

  1. Click on Finder

  2. Click on "Go" from the file toolbar

  3. Click on "Go to folder," close to the bottom of that list

  4. Type in ~/Library then click "Go"

  5. Click on the folder "Internet Plugins"

  6. Delete these files:
    AILPlugin.plugin (may already be deleted)
    npAILPlugin.plugin
    libSLABHIDtoUART.dylib

  7. Then, log into your ALL In Learning account, attempt to grade or use clickers, and follow the steps in the Plugin prompt you will see, to install the current (rolled back) version. Don't forget to restart your browsers afterward.



Additional Keywords: plugin can't won't cannot will can not install plug in mac safari firefox

Powered by Zendesk